A replicação do usuário falha com o erro “Unauthorized” do Anvaigo Server
Sintoma
Falha na replicação do usuário do Anvaigo na configuração do Anvaigo. O log do Anvaigo Server mostra a mensagem de erro “Não autorizado”.
Causa
- Nome de usuário, nome de domínio ou senha estão incorretos.
- O usuário não está configurado como um usuário do Dynamics NAV ou não tem direitos Dynamics NAV.
- Anvaigo Server não está em NTLM = true.
- O serviço Web não está definido para NTLM = true.
- Apenas NAV 2009: A delegação não está devidamente configurada.
Solução
- Abra seu Serviço Web usando http://yourservername/DynamicsNAV/WS/Services usando nome de domínio, nome de usuário e senha com seu Internet Explorer e teste suas credenciais.
DomainUser
Note: DynamicsNAV é o nome da instância do seu serviço web Dynamics. Pode ser diferente como DynamicsNAV70 ou DynamicsNAV80. - Definir Anvaigo Server para NTLM true
- Defina o Web Service como NTLM true e reinicie o Web Service.
Nota para o NAV 2009: Pare o Servidor NAV e o Serviço Web do Dynamics primeiro, depois inicie os serviços novamente. Não reinicie ambos os serviços diretamente. - Apenas NAV 2009: Tente usar Web Services sem delegação primeiro. Configure o serviço web no seu servidor SQL.