Często zadawane pytania / Anvaigo Mobile App / Aplikacja pokazuje „No users found.” przy pierwszym logowaniu.
Jest to tłumaczenie automatyczne. Pierwotne stanowisko jest dostępne w angielski.

Aplikacja pokazuje „No users found.” przy pierwszym logowaniu.

Symptom

Po pierwszym zalogowaniu się do urządzenia mobilnego, Anvaigo Mobile App wyświetla komunikat o błędzie Nie znaleziono żadnych użytkowników.

Przyczyna

Anvaigo Server nie posiada żadnych informacji na temat użytkowników Anvaigo Mobile App. Jest to spowodowane problemem z konfiguracją.

Anvaigo Server nie może komunikować się z serwisem Dynamics, aby zapytać użytkowników z różnych powodów:

  • błędny adres URL usługi dynamicznej
  • ustawienie zapory, które uniemożliwia dostęp z Anvaigo Server do serwisu Dynamics
  • błędna nazwa użytkownika i hasło użytkownika Dynamics, które jest używane w pliku konfiguracyjnym Anvaigo Server.
  • domyślna firma jest zła lub użytkownik nie ma wystarczających uprawnień NAV, aby uzyskać dostęp do tej firmy.
  • Usługa sieci Web nie jest aktywna dla codeunits Task_Communication lub Web_Communication.
  • Serwis internetowy nie zezwala na NTLM.
  • Ze względu na różne zestawy znaków, czasami znaki specjalne nie są dozwolone w hasłach. Należy używać tylko podstawowych znaków.
  • Serwer lub logowanie użytkowników jest włączone, ale folder logowania nie istnieje lub nie ma wystarczających uprawnień.

Rozwiązanie

Sprawdź przyczynę problemu z komunikacją jest plik dziennika serwera Anvaigo.
Znajdziesz ten plik w folderze InstancjiTransfercederserviceTierLog
Szukaj „SyncAllAnvaigoUsers automatically was not successful Exception”:
Na końcu tej linii pojawi się szczegółowy komunikat o błędzie.

Następnie sprawdź ustawienia usługi internetowej w pliku Anvaigo Service Tier.exe.config.

Spróbuj otworzyć serwis internetowy w przeglądarce z serwera z uruchomionym serwerem Anvaigo Server używając h
ttp://servername:7047/DynamicsNAV80/WS/Services Powinieneś uzyskać następujący wynik: Czerwone pola zastępują nazwę instancji.

Jeśli nie widzisz tego ekranu, usługi internetowe lub użytkownik NAV nie jest odpowiednio skonfigurowany.

Jeśli otrzymasz wynik, ale nie widzisz Task_Communicaton lub Web_Communication, aktywuj usługi internetowe dla Anvaigo w konfiguracji Anvaigo Client Suite:

Sprawdź plik konfiguracyjny Web Services, NTLM musi być włączony. Uruchom ponownie usługi internetowe po dokonaniu zmian.