L’applicazione non può connettersi mostrando il messaggio “timeout connessione remota”.
Sintomo
L’accesso ad Anvaigo Server utilizzando Anvaigo Mobile App non riesce con il timeout della connessione remota dei messaggi di errore.

Causa
L’applicazione non riceve alcuna risposta da Anvaigo Server. Questo può essere causato da motivi diversi:
- L’utente ha usato un nome server o una porta sbagliata.
- Anvaigo Server non viene avviato.
- Il firewall centrale non è configurato correttamente per eseguire una mappatura dell’indirizzo IP esterno al Server Anvaigo per le porte tcp/http utilizzate da Anvaigo Server. La mappatura predefinita è 7020 e 7021 tcp.
Non impostare una mappatura per altre porte come 7047 o 8888. - Il firewall del software Windows non consente la comunicazione in entrata per queste porte (7020 o 7021 per impostazione predefinita).
- Un WiFi pubblico non permette di utilizzare queste porte tcp.
Se la comunicazione tra Anvaigo Server e i servizi Web Dynamics non riesce, verrà visualizzato un messaggio di errore diverso.
La soluzione
- Verificare se il nome del server e la porta sono stati digitati correttamente.
- Verificare le impostazioni del firewall come descritto sopra.