App does not initialize showing “Downloading data” permanently.
Symptom
On first login, the Anvaigo Mobile App hangs in process Downloading data. No processing of data is shown, just a download.


In subfolder Transfer\OUT you can see new zip files on every login.
Cause
Anvaigo Mobile uses two communication channels: First is a communication channel using default port 7020. Second is a data transfer channel using default port 7021.
You will get this error if the first communication channel works, but data channel is not set-up correctly.
Possible reasons for this error:
- Firewall is set-up for communication channel (7020), but not for data channel (7021)
- Data channel (7021) uses https, but it is not set-up for your ssl certificate.
- Anvaigo Server cannot create the socket 7021 due to missing rights. You will get an error message in Anvaigo Server log.
Because the Anvaigo Server cannot send data, the zip files remain in folder Transfer\OUT.
Solution
Check your firewall settings for data channel mapping.
Re-run https registration for data channel port.
Open folder Transfer\ANVEOServiceTierLog and (re-) run file ANVEOServiceTier.bat with Administrator rights.
If you have already registered another SSL certificate before for this tcp port, delete your registration first:
netsh http del urlacl url=https://*:7021/
netsh http del sslcert ipport=0.0.0.0:7021

Afterwards, re-run ANVEOServiceTier.bat with Administrator rights.
Some devices require a restart of the device after chaning a certificate. This is caused by a certificate cache on the device.
Give the user the right to create a socket on port 7021. Local Administrator role has the right to do so.