App cannot connect showing message “remote connection timeout”
Symptom
Login to Anvaigo Server using Anvaigo Mobile App fails with error message remote connection timeout.

Cause
The app does not get any response from Anvaigo Server. This may be caused by differend reasons:
- The user has used wrong server name or port.
- Anvaigo Server is not started.
- The central firewall is not set-up properly to do a mapping of the
external ip address to the Anvaigo Server for tcp/http ports used by Anvaigo
Server. Default mapping is 7020 and 7021 tcp.
Do not set-up a mapping for other ports like 7047 or 8888. - The Windows software firewall does not allow incoming communication for these ports (7020 or 7021 by default).
- A public WiFi does not allow to use these tcp ports.
You will a different error message if a communicaton between Anvaigo Server and Dynamics web services fails.
Solution
- Test if servername and port is typed correctly.
- Test firewall settings like described above.