Die Benutzerreplikation schlägt fehl mit dem Anvaigo-Server-Fehler „Nicht autorisiert“.
Symptom
Die Anvaigo-Benutzerreplikation im Anvaigo-Setup schlägt fehl. Das Anvaigo Server-Protokoll zeigt die Fehlermeldung „Nicht autorisiert“ an.
Ursache
- Benutzername, Domainname oder Passwort sind falsch.
- Der Benutzer ist nicht als Dynamics NAV-Benutzer eingerichtet oder hat keine Dynamics NAV-Rechte.
- Anvaigo Server ist nicht für NTLM = true.
- Der Webservice ist nicht auf NTLM = true gesetzt.
- Nur NAV 2009: Die Delegation ist nicht richtig eingerichtet.
Lösung
- Öffnen Sie Ihren Webdienst unter http://yourservername/DynamicsNAV/WS/Services mit Domänenname, Benutzername und Passwort mit Ihrem Internet Explorer und testen Sie Ihre Zugangsdaten.
DomainBenutzerhinweis
: DynamicsNAV ist der Instanzname Ihres Dynamics Webservice. Es kann anders sein als DynamicsNAV70 oder DynamicsNAV80. - Anvaigo Server auf NTLM true setzen
- Web Service auf NTLM true setzen und Web Service neu starten.
Hinweis für NAV 2009: Stoppen Sie zuerst Dynamics NAV Server und Web Service und starten Sie dann die Dienste erneut. Starten Sie nicht beide Dienste direkt neu. - Nur NAV 2009: Versuchen Sie zuerst, Web Services ohne Delegation zu nutzen. Richten Sie den Webservice auf Ihrem SQL-Server ein.