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Die App zeigt bei der ersten Anmeldung „Keine Benutzer gefunden“ an.

Symptom

Bei der ersten Anmeldung mit Ihrem mobilen Gerät zeigt die Anvaigo Mobile App eine Fehlermeldung Keine Benutzer gefunden an.

Ursache

Anvaigo Server verfügt über keine Informationen über Benutzer der Anvaigo Mobile App. Dies wird durch ein Konfigurationsproblem verursacht.

Anvaigo Server kann aus verschiedenen Gründen nicht mit dem Dynamics Webservice kommunizieren, um nach Benutzern zu fragen:

  • falsche Dynamics Web Service URL
  • eine Firewall-Einstellung, die den Zugriff vom Anvaigo Server auf den Dynamics Webservice verweigert.
  • falscher Benutzername und Passwort des Dynamics-Benutzers, der in der Anvaigo Server-Konfigurationsdatei verwendet wird.
  • Standard-Firma ist falsch oder der Benutzer hat nicht genügend NAV-Berechtigung, um auf diese Firma zuzugreifen.
  • Der Webservice ist für die Codeunits Task_Communication oder Web_Communication nicht aktiv.
  • Webservice erlaubt kein NTLM.
  • Aufgrund unterschiedlicher Zeichensätze sind Sonderzeichen in Passwörtern manchmal nicht erlaubt. Verwenden Sie nur einfache Zeichen.
  • Die Server- oder Benutzerprotokollierung ist eingeschaltet, aber der Protokollierungsordner existiert nicht oder hat keine ausreichenden Berechtigungen.

Lösung

Überprüfen Sie, ob der Grund für ein Kommunikationsproblem die Anvaigo Server Log-Datei ist.
Sie finden diese Datei im Ordner TransferANVEOServiceTierLog
Suche nach „SyncAllAnvaigoUsers automatically was not successful Exception:
Am Ende dieser Zeile sehen Sie die detaillierte Fehlermeldung.

Überprüfen Sie dann Ihre Webdiensteinstellungen in der Datei Anvaigo Service Tier.exe.config.

Versuchen Sie, Ihren Webservice in Ihrem Browser von Ihrem Server mit Anvaigo Server unter h
ttp://servername:7047/DynamicsNAV80/WS/Services zu öffnen. Sie sollten das folgende Ergebnis erhalten: Die roten Kästchen ersetzen deinen Instanznamen.

Wenn Sie diesen Bildschirm nicht sehen können, sind Ihre Webservices oder Ihr NAV-Benutzer nicht richtig eingerichtet.

Wenn Sie ein Ergebnis erhalten, aber Task_Communicaton oder Web_Communication nicht sehen, aktivieren Sie die Webservices für Anvaigo im Setup der Anvaigo Client Suite:

Überprüfen Sie Ihre Web Services-Konfigurationsdatei, NTLM muss aktiviert sein. Starten Sie Webservices neu, nachdem Sie Änderungen vorgenommen haben.